K-Tec

Website Stability

  • CarlightExpress
  • CarlightExpress's Avatar Topic Author
  • Offline
  • Main Sequence
  • Main Sequence
More
3 years 2 months ago #99889 by CarlightExpress
Hi all

I've noticed recently that the IFAS website is extremely unstable, a lot of the time I get "Bad Gateway" messages, then a few minutes later the site works again, I get this in work (through US proxy and not through US Proxy), at home and on my mobile so it's not provider specific.

Is there a known issue?

Simon

Please Log in to join the conversation.

More
3 years 2 months ago #99890 by donalmcnamara
Same issues here on similar platforms.
Donal

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #99891 by darragh
Hi,

I have moved the site to a new setup this morning to bring more stability.
If you are still seeing issues, please tell me but I think the instability issues should be gone

Thanks
Darragh

Load averages used to be 26-30 using Apache
now around 0.5 - 0.8 using Nginx and php-fpm

Sniff, sniff, I smell optical cocaine
Last Edit: 3 years 2 months ago by darragh.

Please Log in to join the conversation.

  • CarlightExpress
  • CarlightExpress's Avatar Topic Author
  • Offline
  • Main Sequence
  • Main Sequence
More
3 years 2 months ago #99892 by CarlightExpress
Will keep an eye out Darragh

Coincidentally one of the messages I got earlier was a message from "Nginx" saying bad gateway
The following user(s) said Thank You: darragh

Please Log in to join the conversation.

More
3 years 2 months ago #99896 by albertw
seems much better this evening. no issues so far

Albert White MSc FRAS
Chairperson, International Dark Sky Association - Irish Section
www.darksky.ie/
The following user(s) said Thank You: darragh

Please Log in to join the conversation.

More
3 years 2 months ago #99906 by darragh
Simon,

I used to have nginx reverse proxying to a backend apache instance.
Now the frontend nginx handles all the requests and uses php-fpm for all the php stuff

Regards
Darragh

Sniff, sniff, I smell optical cocaine
The following user(s) said Thank You: michael_murphy

Please Log in to join the conversation.

More
3 years 2 months ago #99911 by Seanie_Morris
Tis working fine today so far.

S.

Midlands Astronomy Club.
Radio Presenter (Midlands 103), Space Enthusiast, Astronomy Outreach Co-ordinator.
Former IFAS Chairperson and Secretary.

Please Log in to join the conversation.

More
3 years 2 months ago #99919 by dmcdona
I saw the Bad Gateway message a couple of times over Xmas but it all came back soon enough.

With the changes you made Darragh, seems that email notification in now turned back on again which is brilliant for me. I rarely load up the website - I just check my email for new topic notifications. Can we please please please keep this going?

Love the new look too by the way. Your (unpaid) work is very much appreciated

Dave

Please Log in to join the conversation.

More
3 years 2 months ago #99928 by donalmcnamara
Well done indeed. Also getting email notifications and log on details are also retained. Thank you.

Please Log in to join the conversation.

  • CarlightExpress
  • CarlightExpress's Avatar Topic Author
  • Offline
  • Main Sequence
  • Main Sequence
More
3 years 2 months ago #100063 by CarlightExpress
Bad gateway happened a few times today, a page refresh sometimes brings it back no problem, but others it takes a few minutes before the site displays properly

Simon

Please Log in to join the conversation.

More
3 years 2 months ago #100064 by darragh
Sorry, was missing around with some configuration, have reset it back to the original, so it should be ok now

Darragh

Sniff, sniff, I smell optical cocaine

Please Log in to join the conversation.

  • CarlightExpress
  • CarlightExpress's Avatar Topic Author
  • Offline
  • Main Sequence
  • Main Sequence
More
3 years 2 months ago #100066 by CarlightExpress
If it's not broken...don't fix it :-)
The following user(s) said Thank You: darragh

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #100071 by Pat_Dunne

darragh wrote: Sorry, was missing around with some configuration, have reset it back to the original, so it should be ok now

Darragh

Since the start of the year I have been finding the forum especially awkward to use on my iPad. Is it possible reset the view of the forum as it was previously in 2013?

Celestron CPC 9.25
Celestron Ultima LX 8mm, 13mm, 17mm, 22mm, 32mm.
Starlight Microfocuser
A full set of Snickers Thermals
Last Edit: 3 years 2 months ago by Pat_Dunne.

Please Log in to join the conversation.

More
3 years 2 months ago #100073 by darragh
Pat,

When I get a chance I'll fix the widths so it will properly across all screens

Regards
Darragh

Sniff, sniff, I smell optical cocaine
The following user(s) said Thank You: mykc

Please Log in to join the conversation.

More
3 years 2 months ago #100074 by Seanie_Morris
Just tried that now myself Darragh and others, the width factor will continue to be worked on so that it will autofit any width and not spill over.

Seanie.

Midlands Astronomy Club.
Radio Presenter (Midlands 103), Space Enthusiast, Astronomy Outreach Co-ordinator.
Former IFAS Chairperson and Secretary.
The following user(s) said Thank You: mykc

Please Log in to join the conversation.

More
3 years 2 months ago #100095 by mykc
Thanks for modifying the forum to make it adjust to the width of the screen. It is now much more user friendly, and the response times are great. Well done, much appreciated.

Mike

Celestron 280 mm f/10 SCT
CG-5 mount
Toolbox full of bits n' bobs
Thermal underwear
The following user(s) said Thank You: darragh

Please Log in to join the conversation.

  • CarlightExpress
  • CarlightExpress's Avatar Topic Author
  • Offline
  • Main Sequence
  • Main Sequence
More
3 years 2 months ago #100098 by CarlightExpress

mykc wrote: Thanks for modifying the forum to make it adjust to the width of the screen. It is now much more user friendly, and the response times are great. Well done, much appreciated.

Mike


Didn't think this was fixed yet, it's not for me, it's probably taking up 50% of my browser width

Please Log in to join the conversation.

More
3 years 2 months ago #100100 by donalmcnamara
It's perfect on the iPhone , but the twitter/ Facebook logos are large on the desktop at work. Definatly getting a lot better though. Well done

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #100104 by Fermidox

CarlightExpress wrote: Didn't think this was fixed yet, it's not for me, it's probably taking up 50% of my browser width


Different in my case, exceeding my browser width by maybe 25%
Last Edit: 3 years 2 months ago by Fermidox.

Please Log in to join the conversation.

More
3 years 2 months ago #100106 by Seanie_Morris
There seems to be an issue with IE and Chrome as it appears fine in Firefox and Safari, and it's also erratic on the machine displaying it too. I am only noticing the exceeded width in Chrome on the machine in studio tonight (first time in a week I could check it on such a wonky machine), while on my laptop and Mac it all appears fine.

Anyway, as I said earlier, the 'fix' is temporary, but please do report back with any layout bugs you spot. Once I think I have the CSS cleaned up and working, I'll post back here for you all to Refresh (hit the F5 key) your browser windows.

Seanie.

Midlands Astronomy Club.
Radio Presenter (Midlands 103), Space Enthusiast, Astronomy Outreach Co-ordinator.
Former IFAS Chairperson and Secretary.

Please Log in to join the conversation.

More
3 years 2 months ago #100123 by Fermidox
All fitting within window now, thanks.

Please Log in to join the conversation.

More
3 years 2 months ago #100125 by mclysaghtn
Hi,

Looks like Internet Explorer version 8 and below has an issue with the screen width. The page width extends past the right hand border by a fixed % irrespective of the screen resolution. If warranted you could look at loading a custom stylesheet for IE Versions 8 and below, using User agent detection or IE Conditional comments.

See.. msdn.microsoft.com/en-us/library/ms537509(v=vs.85).aspx


F.Y.I

The Current Versions of IE, FireFox & Chrome all look fine on Windows OS.

On iphone5/Safari the site is optimised for mobile screen width and also looks fine.

Keep up the good work ;)

Please Log in to join the conversation.

More
3 years 2 months ago #100127 by Pat_Dunne
No improvment on iPad. Still using 20% more than necessary.

Celestron CPC 9.25
Celestron Ultima LX 8mm, 13mm, 17mm, 22mm, 32mm.
Starlight Microfocuser
A full set of Snickers Thermals

Please Log in to join the conversation.

More
3 years 2 months ago #100128 by Seanie_Morris

Pat_Dunne wrote: No improvment on iPad. Still using 20% more than necessary.


Chrome or Safari?

Midlands Astronomy Club.
Radio Presenter (Midlands 103), Space Enthusiast, Astronomy Outreach Co-ordinator.
Former IFAS Chairperson and Secretary.

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #100151 by Pat_Dunne
Safari.

Worked perfectly in the 2013 configuration.

Celestron CPC 9.25
Celestron Ultima LX 8mm, 13mm, 17mm, 22mm, 32mm.
Starlight Microfocuser
A full set of Snickers Thermals
Last Edit: 3 years 2 months ago by Pat_Dunne.
The following user(s) said Thank You: Seanie_Morris

Please Log in to join the conversation.

Moderators: darragh
Time to create page: 0.216 seconds
Powered by Kunena Forum